Affichage sans doublons

Écrivez une version modifiée de l'algorithme ci-dessous, qui affiche exactement les mêmes nombres mais jamais plusieurs fois le même.

$A$ et $N$ sont des entiers naturels
Saisir $A$
$N$ prend la valeur 1
Tant que $N \leq \sqrt{A}$
Si $A \equiv 0 \mod{N}$ alors
Afficher $N$ et $\dfrac{A}{N}$
Fin si
$N$ prend la valeur $N + 1$
Fin Tant Que

Les nombres devront être affiché un par ligne, c'est-à-dire chacun sur sa propre ligne.

Remarque : attention à bien utiliser la division entière et pas la division entre décimaux pour les langages où cela n'est pas le cas par défaut (Python par exemple).


Source : http://www.france-ioi.org/ Créé par : Loïc Février.